This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Frontier Restrict Backend

Sharraxaad

Main Features

  • Users without the capability manage_options (Administrators) will not have access to the backend (admin area, and will be redirected to the home url).
  • Frontier Restrict Backend allows AJAX call such as upload files, but restricted users will not be allowed to access the backend area.
  • Access level chan be changed using a filter – Please see FAQ to allow authors and above to access the back end

Frontier plugins

Rakibaad

  1. ftp the plugin to the /wp-content/plugins/ directory or install it from plugin install on your site
  2. Activate the plugin through the ‘Plugins’ menu in WordPress

SBI

You can change the level that Frontier Restrict Backend blocks, by applying a filter in your functions.php

Per default all other than admin users are blocked, see below example of how to allow Admins, Editors and Authors.

  • manage_options = Administrators
  • edit_others_posts = Editors
  • publish_posts = Authors
  • edit_posts = Contributors
  • read = Subscribers

// ****- Set restrict to allow Author and above -****
function my_restrict_backend_level($min_allow_capability)
{
return “publish_posts”;
}
add_filter(‘restrict_backend_min_cap’, “my_restrict_backend_level”,10,1);

ยด
The above mentioned capabilities that are allowed.

Dibu-eegisyo

Akhri dhammaan 3 dibu-eegis

Ka-qaybgalayaasha & Horumariyayaasha

“Frontier Restrict Backend” waa softiweer il furan. Dadka soo socda ayaa wax ku biiriyay kaabahan.

Ka-qaybgalayaasha

Ku tarjun “Frontier Restrict Backend” luqaddaada.

Ma xiisaynaysaa horumarinta?

Baadh koodka, fiiri bakhaarka SVN, ama iska qor diiwaanka horumarinta adigoo adeegsanaya RSS.

Isbeddellada

1.4.0

  • Tested with WP 5.4

1.3.5

  • Tested with WP 5.2.2 and php 7.2.2

1.3.1

  • Tested with 4.9

1.3.0

  • Fixed issue with Featured image by allowing bypass for async-upload.php & admin-ajax.php

1.2.1

  • Tested with 4.7

1.2.0

  • Added option to control access level from filter – see FAQ .

1.1.0

  • Tested with 4.5
  • Readme update

1.0.3

  • Removed error_log messages

1.0.2

  • Initial release